当前位置: 主页 > 百科 > 计算机编程 > 易语言源码 >
0 Comments

记事本易语言源码编写

发布于:2016-07-05  |   作者:http://www.zxjsq.net  |   已聚集:人围观

.子程序 _编辑框1_内容被改变

.如果 (编辑框1.内容 = “”)

    查找.禁止 = 真

.否则

    查找.禁止 = 假

    查找.正常图片 = #点燃查找

.如果结束

.子程序 _查找_被单击

_启动窗口.编辑框1.获取焦点 ()

如果 (选择框1.选中 = 真)

    区分大写 = 真

.否则

    区分大写 = 假

.如果结束

.如果真 (单选框2.选中 = 真)


    文本位置 = 寻找文本 (_启动窗口.编辑框1.内容, 编辑框1.内容, _启动窗口.编辑框1.起始选择位置 + _启动窗口.编辑框1.被选择字符数 + 1, 区分大写)

    .如果 (文本位置 = -1)

        信息框 (“找不到” + #左引号 + 编辑框1.内容 + #右引号, #信息图标, )

        返回 ()

    .否则

        _启动窗口.编辑框1.起始选择位置 = 文本位置 - 1

    .如果结束

    _启动窗口.编辑框1.被选择字符数 = 取文本长度 (编辑框1.内容)

.如果真结束

.如果真 (单选框1.选中 = 真)

    文本位置 = 倒找文本 (_启动窗口.编辑框1.内容, 编辑框1.内容, _启动窗口.编辑框1.起始选择位置 + 1, 区分大写)

    .如果 (文本位置 = -1)

        信息框 (“找不到” + #左引号 + 编辑框1.内容 + #右引号, #信息图标, )

        返回 ()

    .否则

        _启动窗口.编辑框1.起始选择位置 = 文本位置 - 1

        _启动窗口.编辑框1.被选择字符数 = 取文本长度 (编辑框1.内容)

    .如果结束


.如果真结束


.子程序 _窗口2_创建完毕


查找.禁止 = 真


.子程序 _图形按钮2_被单击


窗口2.销毁 ()


标签:                   喜欢:收藏